Ticket #2308 (closed defect: invalid)

Opened 7 years ago

Last modified 7 years ago

Unable to make install 3.0.1 because /usr/local/man already exists

Reported by: ticket Owned by: somebody
Priority: minor Milestone:
Component: misc Version: 3.0.1
Keywords: Cc:

Description (last modified by khali) (diff)

I'm receiving the following error when trying to do a sudo make install (or make user_install) on 3.0.1:

username@home:~/downloads/lm_sensors-3.0.1$ make user_install
mkdir -p /usr/local/lib /usr/local/include/sensors /usr/local/man/man3 /usr/local/man/man5
mkdir: cannot create directory `/usr/local/man': File exists
mkdir: cannot create directory `/usr/local/man': File exists
make: *** [install-lib] Error 1

Seems like maybe unexpected behavior from mkdir when a subdirectory exists upon parent creation? I'm using Ubuntu 7.10 Gusty.

I have also tried this against SVN with the same results.

Change History

in reply to: ↑ description   Changed 7 years ago by ticket

Oops, I forgot to CC myself :(

  Changed 7 years ago by ticket

Hmm, this might actually be just a configuration issue on my end. My man pages are in /usr/share/man/, so I needed to modify my Makefile to reflect this. Once I did this I no longer received the above error.

Looks like /usr/local/man is supposed to point to /usr/share/man/ on my distro, but I had a broken symlink:

username@home:/usr/local$ ls -la | grep man lrwxrwxrwx 1 root root 9 2007-12-08 15:45 man -> share/man

  Changed 7 years ago by khali

  • priority changed from major to minor
  • resolution set to invalid
  • status changed from new to closed
  • component changed from fancontrol to misc
  • description modified (diff)

"mkdir -p" deals properly with missing parent directories (it creates them on-the-fly) but fails if a parent exists but is not a directory. This includes dangling symbolic links, as you found out.

This is something for you or your distribution to fix, not something lm-sensors should be changed to deal with.

Note: See TracTickets for help on using tickets.