Ticket #2291 (closed defect: worksforme)

Opened 6 years ago

Last modified 6 years ago

lm_sensors chokes on new version of flex

Reported by: ticket Owned by: somebody
Priority: major Milestone:
Component: libsensors Version:
Keywords: Cc:

Description (last modified by khali) (diff)

make fails with:

flex -Psensors_yy -t -Cfe -8 lib/conf-lex.l > lib/conf-lex.c
lib/conf-lex.l:51: bad character: /
lib/conf-lex.l:51: bad character: *
lib/conf-lex.l:51: unknown error processing section 1
lib/conf-lex.l:51: unknown error processing section 1
lib/conf-lex.l:51: unknown error processing section 1
lib/conf-lex.l:51: unknown error processing section 1
lib/conf-lex.l:51: unknown error processing section 1
lib/conf-lex.l:51: bad character: *
lib/conf-lex.l:51: bad character: /
lib/conf-lex.l:57: bad character: /
lib/conf-lex.l:57: bad character: *
lib/conf-lex.l:57: unknown error processing section 1
lib/conf-lex.l:57: unknown error processing section 1
lib/conf-lex.l:57: unknown error processing section 1
lib/conf-lex.l:57: unknown error processing section 1
lib/conf-lex.l:57: unknown error processing section 1
lib/conf-lex.l:57: bad character: *
lib/conf-lex.l:57: bad character: /
lib/conf-lex.l:63: bad character: /
lib/conf-lex.l:63: bad character: *
lib/conf-lex.l:63: bad character: *
lib/conf-lex.l:63: bad character: /
lib/conf-lex.l:69: bad character: /
lib/conf-lex.l:69: bad character: *
lib/conf-lex.l:69: bad character: :
lib/conf-lex.l:69: bad character: `
lib/conf-lex.l:69: bad character: 1
lib/conf-lex.l:69: bad character: 0
lib/conf-lex.l:69: bad character: '
lib/conf-lex.l:69: bad character: ,
lib/conf-lex.l:69: bad character: `
lib/conf-lex.l:69: bad character: 1
lib/conf-lex.l:69: bad character: 0
lib/conf-lex.l:69: bad character: .
lib/conf-lex.l:69: bad character: 4
lib/conf-lex.l:69: bad character: '
lib/conf-lex.l:69: bad character: `
lib/conf-lex.l:69: bad character: .
lib/conf-lex.l:69: bad character: 4
lib/conf-lex.l:69: bad character: '
lib/conf-lex.l:69: bad character: ,
lib/conf-lex.l:69: bad character: `
lib/conf-lex.l:69: bad character: 1
lib/conf-lex.l:69: bad character: 0
lib/conf-lex.l:69: bad character: .
lib/conf-lex.l:69: bad character: '
lib/conf-lex.l:69: bad character: *
lib/conf-lex.l:69: bad character: /
lib/conf-lex.l:73: bad character: /
lib/conf-lex.l:73: bad character: *
lib/conf-lex.l:73: start condition are declared twice
lib/conf-lex.l:73: bad character: *
lib/conf-lex.l:73: bad character: /
make: *** [lib/conf-lex.c] Error 1

Change History

Changed 6 years ago by khali

  • component changed from misc to libsensors
  • description modified (diff)

What version of flex is this, please? And what version of lm-sensors?

Changed 6 years ago by khali

  • status changed from new to closed
  • resolution set to worksforme

No answer for 3 months -> closing. If the problem is real, it will inevitably resurface someday and we'll investigate then.

Note: See TracTickets for help on using tickets.