Ticket #2276 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

sensord --rrd-cgi output has wrong labels

Reported by: ticket Owned by: khali
Priority: major Milestone: 3.0.1
Component: sensord Version: 3.0.0
Keywords: Cc: vcrevot@…

Description

See sample output. It used to work fine with v2. The rrd file seems to be fine.

Attachments

sensord.cgi.orig Download (3.6 KB) - added by ticket 6 years ago.
sensors3.conf Download (1.3 KB) - added by ticket 6 years ago.
sensors-output Download (0.7 KB) - added by ticket 6 years ago.
sensord-fix-rrd-cgi.patch Download (0.8 KB) - added by khali 6 years ago.
Fix for the sensord --rrd-cgi breakage

Change History

Changed 6 years ago by ticket

Changed 6 years ago by ticket

Changed 6 years ago by ticket

  Changed 6 years ago by ticket

NB: the DEF line seem to be fine, the problem is with the associated labels

  Changed 6 years ago by khali

  • owner changed from somebody to khali
  • status changed from new to assigned
  • milestone set to 3.0.1

  Changed 6 years ago by khali

I can reproduce the problem on my system. I've been testing this during the development cycle of version 3.0.0, and it worked back then, so I guess that I broke it shortly before the release.

Changed 6 years ago by khali

Fix for the sensord --rrd-cgi breakage

follow-up: ↓ 5   Changed 6 years ago by khali

The attached patch should fix it, please give it a try and report.

in reply to: ↑ 4   Changed 6 years ago by ticket

It does fix it. Thanks.

  Changed 6 years ago by khali

  • status changed from assigned to closed
  • resolution set to fixed

Fixed by r5069. Thanks a lot for reporting.

Note: See TracTickets for help on using tickets.