Ticket #2230 (closed task: fixed)
Clean up struct sensors_chip_name
|Reported by:||khali||Owned by:||khali|
In the new libsensors code, sensors_chip_name.busname is (ab)used to store the sysfs path to the sensor chip. This doesn't have much to do with a "bus name". At the very least we need a better name, but I am also wondering if we really want to expose this path to the user There might be no easy way around it though.
We also need to introduce a bus type field. For now, positive bus numbers are used for I2C buses, and negative values are used for other buses (PCI, LPC...). But other numbered buses need to be supported as well, like SPI. This means that we want separate struct fields for the bus type and the bus number.
I guess that we can get rid of the "dummy" bus type in the process; not sure what it was supposed to be.