Ticket #2142 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

No CPU temperature display from sensors

Reported by: ticket Owned by: ruik
Priority: major Milestone:
Component: hardware Version:
Keywords: Cc: david.c.hubbard@…

Description (last modified by ruik) (diff)

I have a system with an Asus P5L-VM 1394 (Intel 82945G/GZ/P/PL, ICH7) motherboard running Fedora Core 6. It comes with version 2.10.0 of lm_sensors. With that version, the "sensors-detect" command told me I had an "lm78" sensor chip. When I ran the "sensors" command, I got:

    lm78-isa-0290
    Adapter: ISA adapter
    VCore 1:   +2.30 V  (min =  +2.85 V, max =  +3.15 V)
    VCore 2:   +3.62 V  (min =  +2.85 V, max =  +3.15 V)
    +3.3V:     +3.34 V  (min =  +3.14 V, max =  +3.47 V)
    +5V:       +5.62 V  (min =  +4.76 V, max =  +5.24 V)
    +12V:      +0.30 V  (min = +11.37 V, max = +12.59 V)
    -12V:     -10.85 V  (min = -12.63 V, max = -11.40 V)
    -5V:       -3.71 V  (min =  -5.25 V, max =  -4.74 V)
    fan1:     3082 RPM  (min = 9375 RPM, div = 2)
    fan2:     8881 RPM  (min =   -1 RPM, div = 1)
    fan3:        0 RPM  (min = 51923 RPM, div = 2)
    temp:      +26.0°C  (high =   +24°C, hyst =    +8°C)
    vid:       +3.00 V

As far as I can tell, all those values are correct, but there's no CPU temperature. I even checked in "/proc/acpi/thermal_zone", but that directory is empty. I know the motherboard has an accurate CPU temperature sensor, because it's displayed in the BIOS.

So I tried installing version 2.10.1. The "sensors-detect" from that version tells me:

    Found `Winbond W83627DHG Super IO Sensors'  Success!
       (address 0x290, driver `w83627ehf')

but when I load that driver, I get:

    FATAL: Error inserting w83627ehf (/lib/modules/2.6.18-1.2798.fc6/
        kernel/drivers/hwmon/w83627ehf.ko): No such device

Any idea what I might be doing wrong?

Thanks

Change History

Changed 7 years ago by ruik

  • cc david.c.hubbard@… added
  • owner changed from somebody to ruik
  • status changed from new to assigned
  • description modified (diff)

Hello,

Yes I know :) The support is not yet added. David hubbard is working on this. Please check time to time our "devices" page. I'm ccing the ticket to David.

Rudolf

Changed 7 years ago by ruik

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.