Ticket #2138 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

Patch needed for lm_sensors-2.10.1 on FC3/amd64 2.6.16.20

Reported by: ticket Owned by: khali
Priority: major Milestone:
Component: interface Version: 2.10.1
Keywords: sensors-detect Cc:

Description

To work on FC3/AMD64 with kernel 2.6.16.20 you need to change sensors-detect this way.

The problem is that the return put into $funcs can be bigger than what perl allocates for . For a related discussion see:  http://www.mail-archive.com/fedora-perl-devel-list@redhat.com/msg00591.html

This is probably a 64 bit problem only and/or might only happen with that old perl. Still, you probably want to do what I do below.

Also, FC3 on a mainboard Intel d975xbx (socket 775) will panic a 2.6.16.20 smp kernel when probing i2c_i801 some time after "Client found at address 0x4c" [varying number of "Probing for"] Skipping this client makes things work flawlessly, though. Excellent work overall :-)

Attachments

diff Download (510 bytes) - added by ticket 8 years ago.
sensors-detect-funcs-ioctl-alloc.patch Download (487 bytes) - added by khali 8 years ago.
Preallocate memory space for funcs ioctl

Change History

Changed 8 years ago by ticket

  • attachment diff Download added

Changed 8 years ago by khali

  • owner changed from somebody to khali
  • status changed from new to assigned
  • component changed from misc to interface

The core of the problem seems to be that we aren't properly passing the size (nor direction) in the ioctl function number. OTOH it looks like the kernel code is broken in this respect, so I suspect things would break if we were passing the size and/or direction.

Preallocating the memory space should work as a workaround, however allocating 8 kB for an unsigned int is a bit overkill ;) I'd rather allocate exactly the amount we need, see the attached patch.

As for your other problem, you didn't provide enough details for us to help you, sorry. Please open a separate bug report with all the details if you care.

Changed 8 years ago by khali

Preallocate memory space for funcs ioctl

Changed 8 years ago by khali

  • version set to 2.10.1

Changed 8 years ago by khali

  • status changed from assigned to closed
  • resolution set to fixed

Second patch applied to SVN.

Note: See TracTickets for help on using tickets.