Ticket #204 (closed task)

Opened 8 years ago

make install error (Examined/Solved - lm_sensors 2.4.3 Linux 2.2.12 & Linux 2.2.13)

Reported by: contact Owned by: somebody
Priority: minor Milestone:
Component: interface Version:
Keywords: Cc:

Description

I've patched the kernel and it seems to compile fine. Doing a dmesg I get: i2c-core.o: i2c core module i2c-dev.o: i2c /dev entries driver module i2c-core.o: driver i2c-dev dummy driver registered. i2c-isa.o version 2.4.3 (19991007) i2c-dev.o: Registered 'ISA main adapter' as minor 0 i2c-core.o: adapter ISA main adapter registered as adapter 0. i2c-isa.o: ISA bus access for i2c modules initialized. sensors.o version 2.4.3 (19991007) sis5595.o version 2.4.3 (19991007) i2c-core.o: driver SiS 5595 registered. which looks ok. (I think) But then when I went to make the lm_sensors utils. Make runs ok, but I get this error on a make install. [root@trance lm_sensors2]# make install mkdir -p /lib/modules/2.2.13/misc install -o root -g root -m 644 /lib/modules/2.2.13/misc install: too few arguments Try 'install --help' for more information. make: *** [install-kernel] Error 1 [root@trance lm_sensors2]# I've tried to look at the make file(s) to see if there was any problems, but I can't seem to find the problem. It looks like it is trying to install modules even though I've patched the kernel. BTW, this is RedHat? 6.1 + new 2.2.13 kernel. --- Wierd! Maybe your 'install' is broken? I'll refer this issue to the proper team member. -- Phil I have fixed the error in CVS. In the meantime, it is a good idea to set KERNEL_COMPILE to 0 in the main Makefile

Frodo

Note: See TracTickets for help on using tickets.